0

I have a multisite installation with some site having a bootstrap 3.x theme and a new site that should have a bootstrap 4.x theme.

All BS3 site are using the views_bootstrap module 8.3.x

The new BS4 site should use the views_bootstrap module 8.4.x

views_bootstrap 8.3.x is made to handle BS3

views_bootstrap 8.4.x is made to handle BS4

As I can't upload those 2 versions of this module in the regular /modules/contrib/ folder, the only solution I found was to upload the BS3 version under each /sites/domain/modules/ and same thing for the BS4 version.

Question 1: is-it the correct way to handle this?

I ask, because my nightmare start here: impossible to just move the module. Even by doing the following:

drupal_flush_all_caches(); drush cr; sudo service apache2 restart; 
pc_clear_cache(); $settings['class_loader_auto_detect'] = FALSE;

I end up by :

1-storing all the config files using views_bootstrap

2-uninstall views_bootstrap

3-move views_bootstrap under sites/domain/modules

4-re-install views_bootstrap

5-clear caches

6-re-import the config

But each time the same problem:

PHP Fatal error:  Uncaught Drupal\Component\Plugin\Exception\PluginNotFoundException:
The "views_bootstrap_grid" plugin does not exist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.