0

maybe the solution to my problem is quite simple but I can not find a way on the taxonomy term page to show a menu block!

I use drupal 8 with bartik theme and have a menu based on taxonomic terms (Module: Taxonomy Menu + Menu Block). This menu is also always displayed everywhere (with the set content types). Just not on the taxonomy term page (the page where all entries are displayed from a taxonomy item in a teaser view).

if I look under Structure> Block Layout> Navigation> Configuration: is there "page" there I tried to enter URL of the taxonomy terms or also / * but both remains without effect.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

  • Please post the Visibility settings for your block. – prkos Mar 21 at 16:40
  • ok I have posted a few pictures – s-webz Mar 22 at 11:36
  • Because taxonomy terms are not content types, the visibility setting won’t match – Kevin Mar 22 at 13:22
  • If I got this right, you want the menu to be visible on any page. In this case remove all visibility settings, completely empty visibility setting means "visible everywhere". – Hudri Mar 22 at 13:32
0

As mentioned in comments if you want it shown everywhere you should untick the Type options, then they apply anyway. And on the Seite delete everything, that should show it everywhere too without restrictions (no need for /*).

But I think your particular configuration isn't working because you have included the /de/ in your path under Seite, the language prefix is not part of the Drupal path. Remove it from there and it should work.

Instead of:

/de/tutorial/erste-schritte

it should say:

/tutorial/erste-schritte

You have the Visibility limited to the German language under the Sprache tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.