1

I can't update Drupal 8 from 8.6.10 to 8.6.13 -- please help!

composer.json -- partial

    "require": {
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "^1.4",
        "drupal/core": "^8.6.0",
        "drupal/bootstrap": "^3.11",
        "drupal/views_accordion": "^1.1",
        "drupal/token": "^1.1",
        "drupal/pdf": "1.x-dev",
        "drupal/pathauto": "^1.1",
        "drupal/contact_block": "^1.4",
        "drupal/blocktabs": "^1.0@alpha",
        "drupal/smtp": "^1.0@beta",
        "drupal/viewerjs": "1.x-dev",
        "drupal/group": "^1.0@RC",
        "drupal/field_permissions": "^1.0@RC",
        "drupal/libraries": "^3.0@alpha",
        "drupal/admin_toolbar_tools": "^1.23",
        "drupal/admin_toolbar": "^1.23",
        "drupal/alertbox": "^1.0@beta",
        "drupal/ctools": "^3.0",
        "drupal/login_emailusername": "^1.1",
        "drupal/anchor_link": "^1.6",
        "drupal/download_count": "1.x-dev",
        "drupal/views_data_export": "^1.0@alpha",
        "cweagans/composer-patches": "^1.6",
        "drupal/google_analytics": "^2.3"
    },

composer outdated "drupal/*"

drupal/admin_toolbar       1.23.0       1.26.0      Admin Toolbar improve the default Drupal Toolbar, it lets the hover of sub menus.
drupal/admin_toolbar_tools 1.23.0       1.26.0      Adds menu links to the Admin Toolbar.
drupal/blocktabs           1.0.0-alpha6 1.0.0-beta3 Block Tabs.
drupal/bootstrap           3.11.0       3.17.0      Built to use Bootstrap, a sleek, intuitive, and powerful front-end framework for faster and easier web development.
drupal/coder               8.2.12       8.3.1       Coder is a library to review Drupal code.
drupal/core                8.6.10       8.6.13      Drupal is an open source content management platform powering millions of websites and applications.
drupal/csv_serialization   1.3.0        1.4.0       Provides CSV as a serialization format.
drupal/ctools              3.0.0        3.2.0       Provides a number of utility and helper APIs for Drupal developers and site builders.
drupal/field_permissions   1.0.0-rc1    1.0.0-rc2   The Field Permissions module allows site administrators to set field-level permissions to edit, view and create fields on any entity.
drupal/google_analytics    2.3.0        3.0.0       Allows your site to be tracked by Google Analytics by adding a Javascript tracking code to every page.
drupal/pathauto            1.2.0        1.3.0       Provides a mechanism for modules to automatically generate aliases for the content they manage.
drupal/smtp                1.0.0-beta3  1.0.0-beta4 Allow for site emails to be sent through an SMTP server of your choice.
drupal/token               1.1.0        1.5.0       Provides a user interface for the Token API and some missing core tokens.
drupal/views_accordion     1.1.0        1.2.0       Provides an accordion views display plugin.

composer update drupal/core --with-dependencies

Dependency "asm89/stack-cors" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "composer/semver" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "doctrine/annotations" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "doctrine/common" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "easyrdf/easyrdf" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "egulias/email-validator" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "guzzlehttp/guzzle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "masterminds/html5" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "paragonie/random_compat" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "stack/builder" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony-cmf/routing" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/class-loader" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/console" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/dependency-injection" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/event-dispatcher" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/http-foundation" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/http-kernel" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/polyfill-iconv" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/process" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/psr-http-message-bridge" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/routing" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/serializer" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/translation" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/validator" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/yaml" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "twig/twig" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "typo3/phar-stream-wrapper" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "zendframework/zend-diactoros" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "zendframework/zend-feed" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
  • 2
    Can you try editing composer.json and adding "webflo/drupal-core-strict": "8.6.13" as a requirement, and then doing composer update? If this works, I'll writeup a better answer about what may be going on. – mpdonadio Mar 21 at 20:05
  • White screen of death – jhchnc Mar 21 at 20:38
  • I'm wondering -- is there a way to pinpoint core, instead of doing a full composer update? – jhchnc Mar 21 at 20:38
  • 1
    I think I got past the same thing on a similarly pesky site the other day with composer remove drupal/core; composer require drupal/core:8.6.13 webflo/drupal-core-strict:8.6.13, or something like that – Clive Mar 21 at 20:41
  • 3
    I usually remove composer.lock and vendor directories, and then run composer require drupal/core:8.6.13 in development, and then commit the lock file, and when updating in production "I" run composer install. – mradcliffe Mar 21 at 21:19
2
option 1. composer update drupal/core --with-dependencies
option 2. composer remove drupal/core; composer require drupal/core:8.6.13 webflo/drupal-core-strict:8.6.13
option 3. (if all else fails) remove composer.lock and vendor directories, and then run composer require drupal/core:8.6.13

Pulled from comments so other ppl can read answers instead of looking through comments.

  • 1
    Option 3 worked for me! 1 and 2 failed. Thanks! – arnoldbird Mar 29 at 15:17
0

Updating drupal core is a little different on pantheon. Usually you would apply the update to core via the pantheon ui as seen here. See Drupal Security patches for an alternative method.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.