1

If I add a tag like <script src="http://mysource"></script> in the source code side in CKEditor, it appears well in the WYSIWYG side. But if I go back to source side and come back to the WYSIWYG side it has been transformed like:

<!--{cke_protected}%3Cscript%20src%3D%22http%3A%2F%2Fmysource%22%3E%3C%2Fscript%3E-->

So, I tried to disable Advanced Content Filter by unchecking "Limit allowed HTML tags and correct faulty HTML" and also by using the hook_ckeditor_plugin_info_alter, according to this answer.

I also tried to add allowedContent = true by using ckeditor_config.

Unfortunately without any result.

How to disable this filtering, at least for <script> tag?

I mention that I need the ability to add my <script> tag in CKEditor (my script will load an iframe at this area) and style it.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.