0

I'm working on a Drupal 8 site with a custom theme that I didn't code. The site is using the metatag: favicons module to control the favicons. The favicon seem to work correct on all except the home page, which has the default Drupal "Drop" icon. You can see the site here [Site no fav][1]. I am not sure how to begin debugging this since the behavior is not causing an error and the favicons work on the rest of the pages. I assume this has to be some sort of misconfiguration, somewhere, but I'm not sure if I should be looking in template files, something in the admin UI, or where exactly. Any help/guidance appreciated.

Update: The issue is not a local cache issue, as it was brought to our attention by an external user and happens in Firefox and Chrome.

Update2: Closer inspection of the page source shows that the links for the favicons are indeed not loaded onto the homepage. Specifying a favicon in the Metatag UI for the front page loads one of the favicons. However, the favicons do not have global settings and are still loaded into every other page. The fix of course, is to specify all the icons I want, but this is tedious and doesn't answer why it works on the non-homepage pages.

  • Are you sure your browser hasn’t just cached it for that page? – Clive Mar 25 at 14:02
  • Yes, another user flagged the issue and I've flushed the cache numerous times. Same behavior in FF as in Chrome, Incognito tab shows a blank icon for home page, correct icons for all other pages. – nizz0k Mar 25 at 14:06
  • 2
    In the metatag module the front page has it's own settings. I'm guessing you edited the "Global" settings. But you'll also see a "FRONT PAGE" under the /admin/config/search/metatag admin screen and the front page will be using those settings and not the global ones because the front page has its own set of settings – Leigh Mar 25 at 14:24
  • What @Leigh said. If you keep a go-live checklist for your projects, add that to it. Used to get me every time – Clive Mar 25 at 14:26
  • Alternatively, you could simplify the book work and put the favicon.ico file in the root of your theme. Then drop the metadata settings and in the Appearance / Settings tick the use favicon supplied by theme. – CG Monroe Mar 25 at 14:53
0

In the metatag module the front page has it's own settings. I'm guessing you edited the "Global" settings. But you'll also see a "FRONT PAGE" under the /admin/config/search/metatag admin screen and the front page will be using those settings and not the global ones because the front page has its own set of settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.