0

UPDATE: I am not going to continue to troubleshoot this. Composer is working OK in my local site, so I'm going to change my approach to deployment and stop running composer in my staging site. Instead I will run composer locally, commit core & vendor to the git project, and deploy all code to staging with git.


If I run composer install, I get...

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drupal/core 8.2.x-dev requires symfony/psr-http-message-bridge v0.2 -> satisfiable by symfony/psr-http-message-bridge[v0.2] but these conflict with your requirements or minimum-stability.

However, in the require section of my composer.json, I have...

"drupal/core": "8.6.13"

So why is composer trying to install 8.2.x-dev?

UPDATE: It was suggested I run "composer why drupal/core". Here is the output from that command...

drupal/acquia_connector 1.16.0 requires drupal/core (~8.0)
drupal/address 1.6.0 requires drupal/core (^8.6)
drupal/admin_menu_search 1.0.0 requires drupal/core (~8.0)
drupal/admin_toolbar 1.26.0 requires drupal/core ()
drupal/advagg 3.5.0 requires drupal/core (~8.0)
drupal/advagg_css_minify 3.5.0 requires drupal/core (~8.0)
drupal/advagg_js_minify 3.5.0 requires drupal/core (~8.0)
drupal/allowed_formats 1.1.0 requires drupal/core (
)
drupal/asset_injector 2.4.0 requires drupal/core (~8.0)
drupal/backup_migrate 4.0.0 requires drupal/core (~8.0)
drupal/better_exposed_filters 3.0.0-alpha6 requires drupal/core ()
drupal/block_field 1.0.0-alpha8 requires drupal/core (~8.0)
drupal/block_visibility_groups 1.3.0 requires drupal/core (
)
drupal/block_visibility_groups_admin 1.3.0 requires drupal/core (~8.0)
drupal/business_core 3.0.0-alpha2 requires drupal/core (~8.0)
drupal/config_installer 1.8.0 requires drupal/core (~8.0)
drupal/config_update 1.6.0 requires drupal/core ()
drupal/contact_block 1.4.0 requires drupal/core (
)
drupal/content_export_csv 3.0.0-beta2 requires drupal/core (~8.0)
drupal/content_sync 2.1.0 requires drupal/core ()
drupal/contentimport 4.1.0 requires drupal/core (
)
drupal/contribute 5.0.0-beta3 requires drupal/core (~8.0)
drupal/crop 1.5.0 requires drupal/core ()
drupal/ctools 3.2.0 requires drupal/core (^8.5)
drupal/devel 2.0.0 requires drupal/core (~8.0)
drupal/dropzonejs 2.0.0-alpha3 requires drupal/core (
)
drupal/dropzonejs_eb_widget 2.0.0-alpha3 requires drupal/core ()
drupal/drupal dev-master requires drupal/core (8.6.13)
drupal/embed 1.0.0 requires drupal/core (~8.0)
drupal/encrypt 3.0.0-rc2 requires drupal/core (~8.0)
drupal/entity 1.0.0-rc2 requires drupal/core (^8.6)
drupal/entity_browser 2.1.0 requires drupal/core (~8.0)
drupal/entity_clone 1.0.0-beta3 requires drupal/core (~8.0)
drupal/entity_embed 1.0.0-beta2 requires drupal/core (
)
drupal/entity_reference_revisions 1.6.0 requires drupal/core (~8.0)
drupal/entity_reference_views_select 1.3.0 requires drupal/core ()
drupal/entityqueue 1.0.0-beta1 requires drupal/core (~8.0)
drupal/event dev-1.x requires drupal/core (~8.0)
drupal/facets 1.3.0 requires drupal/core (~8.0)
drupal/features 3.8.0 requires drupal/core (
)
drupal/field_group 1.0.0 requires drupal/core ()
drupal/file_browser 1.1.0 requires drupal/core (
)
drupal/form_placeholder 1.0.0 requires drupal/core (~8.0)
drupal/formblock 1.0.0-beta9 requires drupal/core (~8.0)
drupal/glazed_helper 1.3.0 requires drupal/core ()
drupal/google_analytics 3.0.0 requires drupal/core (~8.5)
drupal/honeypot 1.29.0 requires drupal/core (~8.0)
drupal/image_widget_crop 2.2.0 requires drupal/core (
)
drupal/imce 1.7.0 requires drupal/core (~8.0)
drupal/imce_search 1.0.0 requires drupal/core (~8.0)
drupal/imce_search_plugin 1.0.0 requires drupal/core (~8.0)
drupal/inline_entity_form 1.0.0-rc1 requires drupal/core (~8.0)
drupal/insert_block dev-1.x requires drupal/core ()
drupal/job 3.0.0-alpha2 requires drupal/core (
)
drupal/key 1.8.0 requires drupal/core (~8.0)
drupal/linkit 4.3.0 requires drupal/core (~8.0)
drupal/login_emailusername 1.1.0 requires drupal/core (~8.0)
drupal/material_admin 1.0.0-alpha7 requires drupal/core (~8.0)
drupal/media_bulk_upload 1.0.0-alpha24 requires drupal/core ()
drupal/media_entity 1.8.0 requires drupal/core (
)
drupal/media_entity_browser 1.0.0-beta3 requires drupal/core (~8.0)
drupal/memcache 2.0.0 requires drupal/core (~8.0)
drupal/menu_link_attributes 1.0.0 requires drupal/core ()
drupal/metatag 1.8.0 requires drupal/core (
)
drupal/migrate_file 1.1.0 requires drupal/core ()
drupal/migrate_plus 4.1.0 requires drupal/core (^8.3)
drupal/migrate_source_csv 2.2.0 requires drupal/core (~8.1)
drupal/migrate_tools 4.1.0 requires drupal/core (^8.3)
drupal/minifyhtml 1.7.0 requires drupal/core (
)
drupal/module_missing_message_fixer 1.0.0-beta2 requires drupal/core (~8.0)
drupal/paragraphs 1.8.0 requires drupal/core (~8)
drupal/pathauto 1.4.0 requires drupal/core (^8.5)
drupal/purge 3.0.0-beta8 requires drupal/core (~8.0)
drupal/purge_processor_lateruntime 3.0.0-beta8 requires drupal/core (~8.0)
drupal/purge_purger_http 1.0.0-beta4 requires drupal/core (~8.0)
drupal/purge_tokens 3.0.0-beta8 requires drupal/core (~8.0)
drupal/purge_ui 3.0.0-beta8 requires drupal/core (~8.0)
drupal/redirect 1.3.0 requires drupal/core (~8)
drupal/require_login 2.1.0 requires drupal/core (~8.0)
drupal/rules 3.0.0-alpha4 requires drupal/core (~8.0)
drupal/search_api 1.12.0 requires drupal/core (^8.5)
drupal/search_api_solr 1.2.0 requires drupal/core (~8.0)
drupal/simple_sitemap 3.1.0 requires drupal/core (~8.0)
drupal/simplenews 1.0.0-alpha3 requires drupal/core ()
drupal/smtp 1.0.0-beta4 requires drupal/core (~8.0)
drupal/taxonomy_access_fix 2.6.0 requires drupal/core (
)
drupal/text_summary_options 1.0.0 requires drupal/core (~8.0)
drupal/tfa 1.0.0-alpha4 requires drupal/core (~8.0)
drupal/token 1.5.0 requires drupal/core (^8.5)
drupal/twig_tweak 2.1.0 requires drupal/core (~8.0)
drupal/typed_data 1.0.0-alpha3 requires drupal/core (~8.0)
drupal/video_embed_field 2.0.0 requires drupal/core ()
drupal/view_unpublished 1.0.0-alpha1 requires drupal/core (
)
drupal/viewport 1.1.0 requires drupal/core (~8.0)
drupal/views_bulk_operations 2.5.0 requires drupal/core (^8.4)
drupal/views_infinite_scroll 1.5.0 requires drupal/core ()
drupal/viewsreference 1.4.0 requires drupal/core (~8.0)
drupal/we_megamenu 1.5.0 requires drupal/core (~8.0)
drupal/webform 5.2.0 requires drupal/core (
)
drupal/workflow 1.1.0 requires drupal/core (*)
drupal/workflow_state_config 1.0.0-alpha2 requires drupal/core (~8.0)
drupal/xmlsitemap 1.0.0-alpha3 requires drupal/core (~8.0)

  • 1
    composer why drupal/core might help – Clive Apr 8 at 14:39
  • composer why-not drupal/core ^8.6 provides slightly different info that may also help – gapple Apr 8 at 16:49
  • @Clive I ran that command, and also ran it like "composer why drupal/core 8.2.x-dev", but it's not obvious to me what to do with the output. I don't see any references to "drupal/core 8.2.x-dev" in the output. – arnoldbird Apr 9 at 17:21
  • @gapple I ran the why-not command like you suggested, and the output is 'There is no installed package depending on "drupal/core" in versions not matching ^8.6'. I'm not sure if that tells me anything useful? Thanks. – arnoldbird Apr 9 at 17:22
  • The why-not output seems to indicate that there isn't a restriction that should prevent installing 8.6. Sharing the output from why in your question would be helpful. – gapple Apr 9 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.