0

I'm trying to upgrade an older version 8.5 of drupal core to 8.6.14. I get the following message when I refresh or try to do the update.php on my site:

Warning: Class Drupal\Core\Extension\Extension has no unserializer in Drupal\Core\Cache\DatabaseBackend->prepareItem() (line 167 of core/lib/Drupal/Core/Cache/DatabaseBackend.php).

This is with sites/default/settings.php edited with:

$settings['update_free_access'] = TRUE;

and as this problem has raised its head before here I've added as suggested

$settings['rebuild_access'] = TRUE;

and I've then run site/core/rebuild.php

Still to no avail. Does anyone have any suggestions on what to try next?
I don't have composer or command line on my site. So I can't get drush to clear the cache.

What can I try next?

TIA

  • Hey hey, not clear to me: You updated all files and now want to run the database updates but calling update.php raises this error? Or you trying to upgrade your site calling update.php (which won't work)? – leymannx Apr 14 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.