I am experiencing problems with the captcha module 7.x-1.0-beta1 version. I have enabled captcha in webforms for anonymous users. After submitting the form it repeatedly gives me the error message,

CAPTCHA session reuse attack detected

.. This happens for only one of the webform in which captcha is placed. I am using Drupal 7.2 version.

Any solution for this issue will be really helpful.

  • Have you tried disabling 'Cache page for anonymous users'? – karth Jan 15 '13 at 10:07

I had the same problem because I have an ajax file upload on the form. The solution is to patch the captcha module with the patch found here http://drupal.org/node/918856#comment-6353912 . You just need to download the patch and put it in the same folder and run in command line:

patch < captcha-patch-10022012.patch

if using git, you can just use :

git apply --directory=your/module/derectory captcha-patch-10022012.patch
  • Thanks! Worked for me, had to patch it using PHPstorm, since I'm on Windows (not by choice). Netbeans will patch it, too... for any other Windows users out there! – eidsonator May 22 '13 at 13:04

there is a Patch available for Drupal 7, please check this out: https://www.drupal.org/node/1395184

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.