0

I installed drush 9 and now I'm getting the following error whenever I run a drush command:

/usr/bin/sh: /cygdrive/c/mysite/vendor/drush/drush/drush.launcher: No such file or directory

Details:

  • I have installed drush 9 on Windows 7 using composer. This was an update to my previous drush 8.

  • The drush files are installed in my local site's vendor directory.

  • The drush.launcher file is in the directory indicated in the above error message.

  • To run a drush command, I go to my site's root directory using MINGW64 and run the command using vendor/bin/drush. for example:

vendor/bin/drush drusn --version
  • I have C:\mysite\vendor\bin in my path environment variable.

  • I don't want to use drush.launcher at this time but not sure why it gets invoked and yet not found.

Thank you in advance for your help.

  • I have posted an initial answer below. In general it's easier to help if you provide as much info as possible - the exact version of Drush and Drupal, the environment you are running it in (Cygwin on Windows I assume) and so on. – hansfn Apr 30 at 11:09
  • Thanks @hansfn. This is part of my effort to update my Drupal 8.1.x to 8.6.15 which requires drush 9. Should I have updated Drupal before installing drush 9? – sabz Apr 30 at 16:05
  • No, but you are aware that you should use Composer to update Drupal 8, not Drush? Anyway, if you had indeed correctly upgraded to Drush 9 there should be no drush.launcher. – hansfn Apr 30 at 17:03
  • @hansfn sorry for the confusion. I am using Composer to update Drupal 8. Drush is listed in my composer.json as a dependency with ^9.0.0 but I've had no luck getting it to work. – sabz May 7 at 1:42
  • To repeat myself (as in my answer below). There should be no vendor/drush/drush/drush.launcher. What version does composer info drush/drush return? – hansfn May 7 at 5:47
0

Drush 9 doesn't come with drush.launcher so something is wrong with your Drush installation / update. You should try to fix that by updating or reinstalling Drush. However, in the meantime just delete drush.launcher.

PS! It's recommended to install Drush Launcher in addition to the site-local Drush.

  • thanks for your hint about drush.launcher and that my drush installation is not correct. I still have issues with updating my drush but I'll mark this as an answer since I'm now dealing with a different type of issue. – sabz May 7 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.