1

I set up a subtheme of Bartik in Drupal 7. I also set up the private file system. I was styling everything and when I went to upload a logo, the logo broke. Now the logo url is private://logo_0.png. I cannot remove the logo, disable it via the checkbox, or set it back to default.

I tried some of suggestions from around the net such as using [theme]_preprocess_node. I also tried using a default bartik "template.php" file. (I renamed all the prefixes in it to match my theme name.)

Nothing seems to work and this is the weirdest bug I've EVER encountered in Drupal. Anyone have some suggestions or a push in the right direction to try and fix this?

1 Answer 1

0

I need to disable the Bartik theme completely to make the sub-theme work.

2
  • So you leave the subtheme enabled, and you disable the base theme?
    – Sk8erPeter
    Apr 19, 2012 at 21:50
  • Yes, At first I thought it was a server permissions issue. But after disabling the theme it worked. Although, permissions CAN cause the same problem. Apr 20, 2012 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.