0

I am trying to update a site to Drupal 8.7 and getting a weird set of errors. Can someone point me to how to best diagnose and fix the problem?

Here are the steps that I am taking:

  1. When I try to update Drupal I use:composer update drupal/core webflo/drupal-core-require-dev --with-all-dependencies

This results in

> DrupalProject\composer\ScriptHandler::checkComposerVersion
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drush/drush 9.6.2 requires chi-teck/drupal-code-generator ^1.28.1 -> satisfiable by chi-teck/drupal-code-generator[1.x-dev].
    - drush/drush 9.6.2 requires chi-teck/drupal-code-generator ^1.28.1 -> satisfiable by chi-teck/drupal-code-generator[1.x-dev].
    - drush/drush 9.6.2 requires chi-teck/drupal-code-generator ^1.28.1 -> satisfiable by chi-teck/drupal-code-generator[1.x-dev].
    - Conclusion: don't install chi-teck/drupal-code-generator 1.x-dev
    - Installation request for drush/drush (locked at 9.6.2, required as ^9.0.0) -> satisfiable by drush/drush[9.6.2].
  1. results of composer why-not drupal/core 8.7.0:

    webflo/drupal-core-require-dev 8.6.15 requires drupal/core (8.6.15) drupal/core 8.7.0 requires egulias/email-validator (^2.0) drupal-composer/drupal-project - requires egulias/email-validator (^1.0)

  2. Contents of composer.json:

{ "name": "drupal-composer/drupal-project", "description": "Project template for Drupal 8 projects with composer", "type": "project", "license": "GPL-2.0-or-later", "authors": [ { "name": "", "role": "" } ], "repositories": [ { "type": "composer", "url": "https://packages.drupal.org/8" } ], "require": { "chi-teck/drupal-code-generator": "dev-master", "composer/installers": "^1.2", "cweagans/composer-patches": "^1.6.5", "drupal-composer/drupal-scaffold": "^2.5", "drupal/admin_toolbar": "^1.25", "drupal/chosen": "^2.6", "drupal/ckeditor_a11ychecker": "^1.0", "drupal/ckeditor_balloonpanel": "^1.1", "drupal/ckeditor_div_manager": "^1.0", "drupal/ckeditor_liststyle": "^1.3", "drupal/ckeditor_uploadimage": "^1.7", "drupal/console": "^1.0.2", "drupal/core": "^8.6", "drupal/devel": "^2.0", "drupal/entity_reference_integrity": "^1.0@RC", "drupal/eva": "^1.3", "drupal/imce": "^1.7", "drupal/inline_entity_form": "^1.0@RC", "drupal/ldap": "^3.0@beta", "drupal/markup": "^1.0@beta", "drupal/masquerade": "^2.0@beta", "drupal/migrate_plus": "^4.1", "drupal/migrate_source_csv": "^2.2", "drupal/migrate_tools": "^4.1", "drupal/module_filter": "^3.1", "drupal/readonly_field_widget": "^1.2", "drupal/serial": "1.x-dev", "drupal/taxonomy_access_fix": "^2.6", "drupal/token": "^1.5", "drupal/uuid_extra": "1.x-dev", "drush/drush": "^9.0.0", "egulias/email-validator": "^1.0", "vlucas/phpdotenv": "^2.4", "webflo/drupal-core-require-dev": "^8.6", "webflo/drupal-finder": "^1.0.0", "webmozart/path-util": "^2.3" }, "require-dev": { }, "conflict": { "drupal/drupal": "*" }, "minimum-stability": "dev", "prefer-stable": true, "config": { "sort-packages": true }, "autoload": { "classmap": [ "scripts/composer/ScriptHandler.php" ], "files": ["load.environment.php"] }, "scripts": { "pre-install-cmd": [ "DrupalProject\\composer\\ScriptHandler::checkComposerVersion" ], "pre-update-cmd": [ "DrupalProject\\composer\\ScriptHandler::checkComposerVersion" ], "post-install-cmd": [ "DrupalProject\\composer\\ScriptHandler::createRequiredFiles" ], "post-update-cmd": [ "DrupalProject\\composer\\ScriptHandler::createRequiredFiles" ] }, "extra": { "patchLevel": { "drupal/core": "-p2" }, "installer-paths": { "web/core": ["type:drupal-core"], "web/libraries/{$name}": ["type:drupal-library"], "web/modules/contrib/{$name}": ["type:drupal-module"], "web/profiles/contrib/{$name}": ["type:drupal-profile"], "web/themes/contrib/{$name}": ["type:drupal-theme"], "drush/Commands/{$name}": ["type:drupal-drush"] }, "drupal-scaffold": { "initial": { ".editorconfig": "../.editorconfig", ".gitattributes": "../.gitattributes" } } } }

  1. Results from composer outdated: alchemy/zippy 0.4.3 0.4.9 chi-teck/drupal-code-generator dev-master 8209866 dev-master 4960fe0 dflydev/dot-access-data v1.1.0 v2.0.0 drupal/core 8.6.15 8.7.0 egulias/email-validator 1.2.15 2.1.7 league/container 2.4.1 3.2.2 paragonie/random_compat v2.0.18 v9.99.99 phar-io/manifest 1.0.1 1.0.3 phar-io/version 1.0.1 2.0.1 phpdocumentor/type-resolver 0.4.0 0.7.1 phpunit/php-code-coverage 5.3.2 7.0.3 phpunit/php-file-iterator 1.4.5 2.0.2 phpunit/php-timer 1.0.9 2.1.1 phpunit/php-token-stream 2.0.2 3.0.1 phpunit/phpunit 6.5.14 8.1.3
    phpunit/phpunit-mock-objects 5.0.10 6.1.2 Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested. ralouphie/getallheaders 2.0.5 3.0.3 sebastian/comparator 2.1.3 3.0.2 sebastian/diff 2.0.1 3.0.2 sebastian/environment 3.1.0 4.2.1 sebastian/global-state 2.0.0 3.0.0 sebastian/resource-operations 1.0.0 2.0.1 stecman/symfony-console-completion 0.9.0 0.10.0 symfony-cmf/routing 1.4.1 2.1.0 symfony/config v3.4.27 v4.2.8 symfony/console v3.4.27 v4.2.8 symfony/css-selector v3.4.27 v4.2.8 symfony/debug v3.4.27 v4.2.8 symfony/dependency-injection v3.4.27 v4.2.8 symfony/dom-crawler v3.4.27 v4.2.8 symfony/event-dispatcher v3.4.27 v4.2.8 symfony/filesystem v3.4.27 v4.2.8 symfony/finder v3.4.27 v4.2.8 symfony/http-foundation v3.4.27 v4.2.8 symfony/http-kernel v3.4.27 v4.2.8 symfony/phpunit-bridge v3.4.27 v4.2.8 symfony/process v3.4.27 v4.2.8 symfony/routing v3.4.27 v4.2.8 symfony/serializer v3.4.27 v4.2.8 symfony/translation v3.4.27 v4.2.8 symfony/validator v3.4.27 v4.2.8 symfony/yaml v3.4.27 v4.2.8 twig/twig v1.40.1 v2.9.0 typo3/phar-stream-wrapper v2.1.0 v3.1.0 vlucas/phpdotenv v2.5.2 v3.3.3 webflo/drupal-core-require-dev 8.6.15 8.7.0 zendframework/zend-diactoros 1.8.6 2.1.2

Per suggestion from @fgrep, I removed composer.lock and vendor/. The result was even more errors: (see File linked as question was getting to long)

1

I fixed it by deleting composer.lock and vendor:

rm -Rf composer.lock vendor/

Then I ran a composer update:

composer update
  • thank you for the suggestion, but that did not work. I will edit my question to add in the results of that command. – Kevin Finkenbinder May 7 at 19:07
0

The problem turned out to be that the composer.json had a requirement for "egulias/email-validator": "^1.0" and 8.7 requires 2.0. I could not find any reason why 1.0 was in the requirements. When I removed that requirement, the update proceeded without any problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.