0

When I try to use a Drupal Console command, even a simple a drupal list, I get an error.

Fatal error: Class 'CommerceGuys\Addressing\AddressFormat\AddressFormatRepository' not found in /path/to/my_project/web/modules/contrib/address/src/Repository/AddressFormatRepository.php on line 16

Of course, the last AddressFormatRepository extends the other and has
use CommerceGuys\Addressing\AddressFormat\AddressFormatRepository as ExternalAddressFormatRepository;.

The namespace is good, classes exist, so I don't understand why I get the error.

The composer.json file contains the following lines.

"drupal/address": "~1.0",     
"drupal/console": "^1.0.2",    
"drupal/core": "^8.6.0",    

I tried to update the Address module, manually install the dependencies with Composer, but nothing changed.

Do you have any idea?

  • Have you tried composer dump-autoload? – Clive May 14 at 8:32
  • Yes I tried, but nothing more. I think composer install/update do it automatically ? – Rémi May 14 at 8:41
  • Yeah it does, but sometimes things get out of sync. Always worth a try at least – Clive May 14 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.