Drupal 7 site. For over 5 years we've had no trouble uploading images to view with a blog. This weekend we had Ningx loaded on our server. Hosting co. is certain that's not issue. Maybe it isn't. But...

What is happening is when we upload File Type of Image it now puts it in "/files" folder. Not the subfolder under it: "files/styles/wnhs870x325/public" designated by the Image Style. If I manually copy the file over to subfolder image displays correctly.

Any ideas why the image is uploading to one location but looking for it in another.

Thanks -Neil

  • Images with styles applied are generated on the fly, when the URL is first accessed. The original file is always uploaded somewhere outside the files/styles/ folder. If you're getting 404s for the image styles, and you've just moved to nginx, it's pretty likely that the vhost is missing some required config for those image style paths – Clive May 15 at 19:05
  • Clive - can you share what that config setting might be. Or where one finds it? Thanks, Neil – Neil May 16 at 13:38
  • Something like drupal.stackexchange.com/a/198301/2800. But I wouldn't advise applying that rule unless you're comfortable with exactly what it means, and with thought to how it might apply in the context of the rest of the conf file. It's too easy to fix one thing and inadvertently break another. I'd recommend outsourcing this to someone with specific Drupal/Nginx experience. – Clive May 16 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.