0

I created a view in Drupal 8 with 2 displays. I want to keep a display content view mode as teaser and the other as featured (custom), but when I change a display it updates the other display as well.

screenshot

1

It's easy to miss if you're always clicking on the | Settings link of an Option.

Options can be set to apply to All displays or you can override for each Display separately This attachment (override).

But you have to click on the Option itself and not its "Settings" link to see that Dropdown.

You clicked on the "Teaser" or the "Featured" Settings link of your Show Option, but there is no Dropdown to override there.

You have to click on the Content link first, Override through the Dropdown for this Attachment only and Apply (this display). Then you can change the Settings for the Option if you have to. It will only apply to the current Display.

You can change the original Display Option to what you want and Apply to all displays, that one doesn't have to be overridden, unless it makes sense for that particular case.

  • I got it.. thank you so much!! – Mamallan May 28 at 6:05
0

You need to first select content and change the setting to this attachment override. Then select the mode. Like the below image.

Override the current view

  • I got it..Thank you so much for the screenshot. – Mamallan May 28 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.