After performing a Drupal core update on my site today I've found that I can no longer access translated content. When I try to view or edit the translation, I only see the default language content.

I created a short GIF you can view here:


As you can see, I'm editing the node for Canada and the US translation is showing instead. Translations were working fine with Drupal 8.6.2 but began to do this in 8.6.3. I have now done the following with no success:

  • Updated to the latest Drupal core 8.7.2
  • Updated all installed modules
  • Created a new Drupal site with 8.6.3 and 8.7.2, but this issue does not exist
  • Disabled Workbench moderation for a given content type, but that doesn't fix the issue

I'm really not sure where and or how to troubleshoot this issue. Where would you start?

I'm thinking I could start by uninstalling modules to see which is possibly causing the issues. I'm not sure if that is the right approach given that this issue began when I updated the Drupal core, not the modules.

Thank you for any feedback!

1 Answer 1


Turns out this issue was due to my settings on the Detection and selection page at /admin/config/regional/language/detection. I reordered URL to be above User and the translations are now showing.

enter image description here

Hopefully, this is able to help someone else in the future.

  • 1
    Yes, you always have to be careful about those settings. They allow you to set it as you like, but many combinations aren't very usable. I found turning on User and URL method at the same time doesn't make much sense. If User has priority then when logged in you'd never be able to see the site in any other language but the one from your preferences, a change in the URL does nothing in this case. If you want URL to "rule" then it makes sense to offer the Language switcher for users, an "outside" influence. It's best to enable as few of these options as possible.
    – prkos
    May 30, 2019 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.