0

I'm fairly new to Drupal, the inside settings are quite easily to understand for me but when it gets to error fixing I'm kind getting stuck sometimes.

For a project I've installed the Open Social platform as my Drupal, which is working fine but a couple bugs and things for me to find out. I wanted a file browser as a Knowledge Base into my site so I've installed the FileBrowser module.

Now when I want to specify (open social) group rights to a file browser node, so only that group can look into this file browser, I get the following error and I cannot seem to find out where to solve it:

Uncaught PHP Exception Drupal\\Component\\Plugin\\Exception\\PluginNotFoundException: Plugin ID 'group_node:dir_listing' was not found.

Could anyone point me into the right direction?

  • Did you look at the backtrace information which code is trying to load the non-existing plugin? – 4k4 May 29 '19 at 9:57
0

It looks like the error is coming from a missing plugin provided by the group_node module, which if I recall ships with the Group module. Try re-downloading that module to your codebase, and clearing your cache. If that doesn't work, uninstall the group_node module.

| improve this answer | |
  • Shamefully when I overwrite the module with a fresh downloaded one, it removes the entire option to be able to add group permissions so it seems like I'm going to have to find the problem in the code. – ronald1993 Jun 3 '19 at 5:47
  • You probably have to enable the content type in the group settings. – Jaypan Jun 3 '19 at 6:11
  • Yes this has solved my issue! Thankyou for the help. – ronald1993 Jun 3 '19 at 10:12
  • Glad it worked out :) – Jaypan Jun 3 '19 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.