I'm trying to update the Drupal Core of a website, specifically from 7.65 to 7.67. I've followed the instructions from here. After the process, I've try to access the website without luck, because I'm getting the following error: Fatal error: Class 'DrupalDefaultEntityController' not found in /var/www/html/modules/comment/comment.module on line 1698

I've tried to run the update.php file and clearing the cache from the db several times, without fixing the error. I've also tried to update from 7.65 to 7.66, but the problem persists.

What am I doing wrong?


I've tried to follow the instructions written here suggested by the user sivani. Here is the message I am getting:

DRUPAL_ROOT is /Users/DamianFox/tests/drupal-website/website.<br/>
Bootstrapping to DRUPAL_BOOTSTRAP_SESSION<br/>
<h1>Additional uncaught exception thrown while handling exception.</h1><h2>Original</h2><p>PDOException: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: nodename nor servname provided, or not known in lock_may_be_available() (line 167 of /Users/DamianFox/tests/drupal-website/website/includes/lock.inc).</p><h2>Additional</h2><p>PDOException: SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: nodename nor servname provided, or not known in system_list() (line 165 of /Users/DamianFox/tests/drupal-website/website/includes/module.inc).</p><hr />%
  • Is /var/www/html/includes/entity.inc present and readable by the web server? – Clive Jun 3 '19 at 14:02
  • It should be readable by the web server. I've checked the permissions and I've got this: -rw-r--r--@ – DamianFox Jun 3 '19 at 14:10
  • Ok, so it's (probably) either that, which assuming MacOS you can clear with xattr -c /path/to/entity.inc, or something's gone wrong with the only other module that usually has any dealings with that file beyond a core install and update: the Entity API module. It's difficult to guess further without access to the server unfortunately – Clive Jun 3 '19 at 14:22
  • Ok. I tried the xattr, but it didn't work. I'm running the Drupal website in a Docker container. Maybe it has something to do with yml files? – DamianFox Jun 3 '19 at 15:49
  • just follow this instruction drupal.org/project/registry_rebuild . I hope this will help for you – sivani Jun 4 '19 at 15:01

After a bit of research, I found out that the problem might be generated from entity.inc inside the includes folder.
Therefore, I tried to put back the previous entity.inc (from the 7.65 installation); subsequently, I run the update.php script, and after another refresh, the website is finally accessible.
I done few more tests to check if there are warnings or errors, but everything seems to work fine, so somehow I got it sorted.


Try drush rr --fire-bazooka and see if that helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.