0

I created a view block and placed it in the content region. There is no role restriction. That means all users can view the block. However, only authenticated users can view the block. I am not sure how to fix it.

screenshot

How can I display the block to public?


enter image description here

5
  • 1
    Doesn't sound anything to do with the block itselfs and more likely to do with your view. Check within your view there's permissions in therea and also anon users might not have permission to view the content your displaying within your view so that's worth checking too
    – Leigh
    Commented Jun 5, 2019 at 13:18
  • I checked the views and it looked correct. Please see the update.
    – autop
    Commented Jun 5, 2019 at 15:31
  • It will be cached, try clearing the caches Commented Jun 5, 2019 at 16:07
  • 1
    Do you have access restrictions on the content that view is returning? If that's the case, anonymous users will never see that content because by default SQL rewriting is enabled. You'd need to disable SQL rewriting in your view. See drupal.stackexchange.com/questions/270298/…
    – mradcliffe
    Commented Jun 5, 2019 at 19:20
  • Public did not have access to the content type as per requirement. Because of that, they cant see the view. I guess I need to change the requirement. Thanks!
    – autop
    Commented Jun 6, 2019 at 12:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.