0

I'd like my JSON:API responses to return the e-tag header so that consuming remote sites can determine (e.g. with a HEAD request) if they need to ditch their cached responses and re-fetch. There is no last-modified or e-tag headers being sent at all - for any Drupal page for that matter. How can I enable this? Thanks!

I do see X-Drupal-Dynamic-Cache and X-Drupal-Cache headers, but this isn't enough to go on.

Running Drupal 8.6.10 and JSON:API 8.x-2.4.

1

I changed the "Browser and proxy cache maximum age" setting in Configuration > Development > Performance and it appeared to do the trick. It was previously set to "no caching".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.