0

I installed Drupal using the Bitnami stack. I'm trying to install the knowledge base module from https://www.drupal.org/project/kb . I have installed and enabled the modules upon which it is dependent but when I try to enable the knowledge base module itself I get the error

Unable to install KnowledgeBase due to unmet dependencies: core.entity_form_display.node.kb_content.default (field.field.node.kb_content.body)

Obviously I am still missing a dependency and it's telling me what it is but what is but how do I fulfill the requirement?

Further, I can see the core.entity_form_display.node.kb_content.default yml file in C:\Bitnami\drupal-8.7.2-1\apps\drupal\htdocs\modules\kb\config\install when I use file explorer.

Is the yml file in the wrong place? Or do I need to do something with it so the knowledgebase install knows about it?

Can someone tell me what I need to do? Please excuse if it's obvious I am a newbie to Drupal.

Thanks for any help, Roscoe

0

The install yml is not in the wrong place. This is a new module with 1 install currently in beta state so you might face a few problems with it if not all bugs are not ironed out but perhaps this is not the case.

The error message is not that helpful I must admit. If you want to see what dependencies you are missing you go into the .info.yml file and can also be seen online here and here is the relevant section

...
dependencies:
  - drupal:field
  - drupal:file
  - drupal:text
  - drupal:node
  - drupal:group
  - drupal:gnode
  - drupal:views
  - drupal:views_jump_menu
  - drupal:eva

for field, file, text, node, views are part of core (nothing to do)

but you have to download https://www.drupal.org/project/group (for group and gnode) https://www.drupal.org/project/views_jump_menu https://www.drupal.org/project/eva

before you are able to install this module

I suggest that you start looking into installing things using composer that takes care of the dependencies for you so if you did

composer require drupal/kb 

all the dependencies would also be installed for you

More info about composer based drupal installations can be found here and here and perhaps other places but those are good starting points

  • Hi GiorgosK thanks for the quick reply. Taking another look at he kb Drupal site at drupal.org/project/kb I see that my issue is an open bug previously reported on a composer download at drupal.org/project/kb/issues/3051986 . I think I will look for another more mature solution for a knowledge base. Perhaps a combination of wikki with QandA with a bit of document storage would work. I was really trying to find a canned solution though if you have any recommendations. I will check the bug reports in future. Thanks for the lesson I'm a newbie, Cheers, Roscoe – rpf Jun 11 '19 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.