0

I'm trying to create a topic page for "internet of things", but each time I create the page I notice the URL slug removes the word "of" in it. By default Generate automatic URL alias is checked. The only solution I have found is to uncheck the Generate automatic URL alias option and giving custom url alias. This is a problem since we have alot pages and it's difficult to update it manually. (Some people who make these pages don't have permission to open drupal and push changes from our website). We also run into an issue with symbols # or + or character 'a'.This is restricting the SEO for pages like C#

  • 3
    The settings are at /admin/config/search/path/settings – Clive Jun 14 at 11:15
1

With just the Path module you can only edit each alias one by one manually.

If you want more control than the Path module allows you can use the Pathauto module. That module has a setting listing all words to exclude from the generated paths. Delete the of and a from that list if that is what you need. There are also options about how to deal with many special characters under Punctuation settings.

Be very careful with the # since it has meaning in URLs, it denotes an ID of an anchor on that page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.