0

I've looked at other posts but been unable to resolve the issue. I have a Text field (formatted, long) in a content type, when the node is viewed the HTML in the field displays correctly, when I view the fields in the database it is stored as raw HTML, however, when I add one of these fields to my view, the output is escaped as < and so on and therefore displayed in the browser as HTML rather than marking up the text.

I've seen a few posts suggesting modification of the twig template, however a) this didn't seem to work for me and b) I'm looking to do this within the view / module so it is applicable regardless of which theme is in use.

Any suggestions?

  • What are your field Formatter and Rewrite results settings? Does it work well in Views Preview or in Bartik theme? – prkos Jun 14 at 12:57
  • The dev theme is Bartik, will be working on the new theme when the structure is sorted. Formatter has been tried in Default and trimmed and I get the same result. No rewrite enabled Get the same on preview and when viewing the page, have tried viewing on incognito window without logging on so see the same whether anonymous user or logged in administrator. – Alex Monaghan Jun 14 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.