0

I'm trying to launch a Quick Start distro on macOS with MAMP:

[519] : php core/scripts/drupal -vvv --verbose  quick-start

 Select an installation profile [Install with commonly used features pre-configured.]:
  [standard  ] Install with commonly used features pre-configured.
  [minimal   ] Build a custom site without pre-configured functionality. Suitable for advanced users.
  [demo_umami] Install an example site that shows off some of Drupal’s capabilities.
 > demo_umami

Creating file: sites/default/settings.php
18/18 [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓]
Congratulations, you installed Drupal!
Username: admin
Password: hIuWCqqnaD-TostT
Drupal development server started: <http://127.0.0.1:8888>
This server is not meant for production use.
One time login url: <http://127.0.0.1:8888/user/reset/1/1560664888/oDldybNCOH_0nRc1n4YXZWm2NwEehXnN63rWHq_Isqo/login>
Press Ctrl-C to quit the Drupal development server.
Browser command: open 'http://127.0.0.1:8888/user/reset/1/1560664888/oDldybNCOH_0nRc1n4YXZWm2NwEehXnN63rWHq_Isqo/login?destination=%2F'
Server command: '/Applications/MAMP/bin/php/php7.2.1/bin/php' '-S' '127.0.0.1:8888' '.ht.router.php'

Unfortunately the given URL returns with HTTP error code 500. Also I added -vvv and --verbose no additional error messages are visible.

When I change from MAMP to OS X standard PHP installation the browser shows:

Warning: Unknown: failed to open stream: No such file or directory in Unknown on line 0

Fatal error: Unknown: Failed opening required '.ht.router.php' (include_path='.:') in Unknown on line 0

Actually there's no .ht.router.php from where I started the quick-start command.

Any ideas?

  • Seems to be more of a MAMP issue. Probably same happens when installing a WordPress for example, no? – leymannx Jun 16 at 6:39
  • Well it also happens without MAMP. What about the missing file? – BetaRide Jun 16 at 6:42
  • Maybe redownload it from somewhere. Does a normal site installation work? Like with adding a host to MAMP and then accessing hostname/install.php in your browser? – leymannx Jun 16 at 6:53
  • I didn't think quick-start worked on anything but native PHP as it was designed to give an evaluator something to spin up a Drupal site within 3 commands using PHP's native web server without requiring a full stack. Additionally the "Quick Start" project is not the same as the "quick-start "command. Are you trying to test one or the other? – mradcliffe Jun 17 at 12:41
  • The quick-start core command worked fine for me just now. I made sure I was not running any web server and cleared any existing settings.php file that I had to make sure I was running it cleanly. – mradcliffe Jun 17 at 12:46
1

Well that was a nasty one. I downloaded and unpacked the latest Drupal version as instructed. But then made a copy using Finder. Unfortunately this leaves out the all files starting with a ..

After copying the files on the comannd line everything works as ecpected. Thanks to @leymannx for pushing me into the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.