I've got some custom content translated with entity translation with custom taxonomy also translated. Actually taxonomy terms are correctly shown inside the content page. The problem is I need different taxonomy terms for different translation. When I change the taxonomy terms in the translation edit page every translation of the content gets updated with the terms variation.

The logic behind would be:

- content A (english) --> taxonomy term 1 (english)
- content A (french)  --> taxonomy term 2 (french)
- content B (english) --> taxonomy term 2 (english)
- content B (french)  --> taxonomy term 3 (french)

1 Answer 1


If you don't want the node translations to share the terms they are tagged with you need to make the Taxonomy term reference field translatable. Then you will be able to enter different values into that field depending on which language you're editing.

You can enable the translations for Fields under Configuration > Regional and language > Content language and translation (/admin/config/regional/content-language).

Tick the box for your Taxonomy field and hit the "Save configuration" button at the bottom of the page.

After that you'll be able to save the translations with different values for that field than the original. The translations in languages other than the default one will probably have that field empty before you edit them, they will not "inherit" the values from the default translation out-of-box.

  • I'm not finding this setting page you are suggesting. Maybe because taxonomy are translated with entity translation. There will be any conflicts enabling multilingual modules for taxonomy translation? Commented Jun 19, 2019 at 9:42
  • I assumed it was about D8. I have noticed incompatibilities between Entity translation and Multilingual select module. Do you have them both enabled? Have you followed the instructions for the Entity Translation module configuration? drupal.org/docs/7/modules/entity-translation/…
    – prkos
    Commented Jun 19, 2019 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.