1

Using the Webform module 8.x, I would like that the email sent with the webform_submission_values doesn't include the fieldset labels.

How can I achieve this?
Alternatively, is there a way to not send the Page label in the email?

In my case, page label and fieldset label are the same. The confirmation email shows the same value twice.

3
  • Why not just use the option to customise the content and add tags for the fields? Jun 19, 2019 at 15:53
  • Reason is I have a few dozen fields and did not want to add a line for each field. Was trying to just use the [webform:submission:values] tag but somehow not have either the page label or the fieldset label be sent with the email.
    – penone
    Jun 19, 2019 at 16:13
  • 1
    I think the submission is themable as webform-submission.html.twig. I'd suggest looking into that option. Jun 19, 2019 at 16:43

1 Answer 1

0

You could check out the hook preprocess_webform_confirmation. There you can strip out what you want from the confirmation message.

There is a quite good example over here: https://agileadam.com/2020/04/overriding-a-webform-confirmation-message-in-drupal-8/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.