0

I want to add a Display Suite token field to my Custom Block Type.

  1. I have a custom block type.
  2. I created a token field with Display Suite
  3. Entities: Block Content
  4. Limit field *|* or link_card|* where link_card is the machine name of my custom block type

I expect to be able to go to Manage display of my custom block type and see the token field I created, but it's not there. I have successfully made token fields and added them to Content Types.

What am I missing?

--

UPDATE: Whatever this was, it resolved itself. Shrug!

1

Does it work when you don't limit?

And just to be double sure.... you have got to Structure > Block Layout > Types > (actual type) > Manage Display. And once there, in the bottom area where it says "Layout for basic in default", you selected a "Select a layout" of something other than "-None-". Because the fields won't show until you select a Display Suite layout.

| improve this answer | |
  • I do not have that option for some reason. All I have is a checkbox to use Layout Builder. On my content types as well. I'm realizing this has to be something wrong with the way our team is managing modules or something. We've moved in a different direction since I asked this question, and since I think this is wonky on our end, I'm going to archive this question. Thank you very much, though. – Sarah C Jun 26 '19 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.