0

We are attempting to push a content type from our Drupal site to a Salesforce object. We have successfully authorized the link between them. When we attempt to start the mapping, we get an AJAX error. I believe the AJAX error is just a symptom of the real error that occurs within the Salesforce module so I am not providing much about it.

In the logs after the error has been triggered, the drupal log shows 2 errors:

Notice: Undefined offset: 8 in salesforce_mapping_form_validate() (line 590 of /.../sites/all/modules/contrib/salesforce/modules/salesforce_mapping/includes/salesforce_mapping.admin.inc).

and

Warning: Invalid argument supplied for foreach() in form_type_checkboxes_value() (line 2394 of /home/tim/projects/lca/includes/form.inc).

I have attempted to use xdebug to watch this process as it works its way through the salesforce_mapping.admin.inc processes, but nothing has jumped out at me. In the end, phpStorm runs out of memory and stops processing the request. The next page load of drupal crashes the browser window as well leading me to believe there is some sort of recursive error happening.

I have searched this modules issue queue and the interwebs extensively, but nothing fits our situation. Please let me know if I can provide further information for you or can otherwise assist.

1 Answer 1

0

I found the issue. For anyone in the future running into this error, I found that you must have both the push and pull submodules enabled for the mapping to work. I was only planning to push records into Salesforce so I mistakenly assumed I didn't need the pull modules enabled. With it enabled, the mapping worked like a champ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.