0

I want to know How to set "Language Selector Drop-Down " required in node form?

I tried to do this via hook_form_alter, but it seems $form['language'] is not created in this hook !

Is there any hook that let me modify language Drop-Down selector?

0

I found the solution here

You can enable i18n_node module that is included in i18n module. Then:

    Go to edit the content type (admin/structure/types/manage/page).
    Open the 'Multilingual settings' tab.
    Check the 'Require language' checkbox.

Done.

Multilingual content must be installed at first and then in content type, Multilingual settings tab will be added

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.