2

I have installed the mayo theme on my new site. When I try to go to "appearance" menu, and change the color combination from mayo (default) to anything else, the system saves the settings. but the website is not using the colors I chose.

What could be the cause?

I'm trying to change colors, but nothing I do works; the colors are correct only with the default color combination.

  • Does the color switching function work with Bartik or Garland, the pre-installed core themes? If no, it could be a problem with your files directory. – Patrick Kenny Apr 15 '12 at 0:34
1

Have you installed the theme in the right location (sites/all/themes)? If so, verify that each template has a CSS file for it. If so, then the next place to check is within the template's .info file to ensure that the CSS file is indeed being used.

Perhaps this thread would help assist you: http://drupal.org/node/1118068

0

This is almost guaranteed to be a permissions problem.

The color module relies on rewriting CSS files so you have to have your "files" folder correctly configured and with 777 permissions and also you should have your temporary directory working properly.

Have you tried checking out your Status Report (admin/reports/status) to see if there are any warnings about directory permissions?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.