0

I have enabled Commerce Stock Modules and its submodules 1. Commerce Stock API
2. Commerce Stock Field
3. Commerce Stock Local Storage
4. Commerce Stock UI

Created a Product Type ABC and added a field field_stock(field type Stock Level ) under fields section of Product Type ABC
Under Commerce >> Configuration >> Stock
I have set the default configuration for STOCK SERVICES as - Use Default -

and default value is set to Local Stock

enter image description here

and when I edit the products I see it as

enter image description here

What am I missing I have added a field but it does not show the text value
where I can add quantity for a product ?

1

You need to configure the Stock Services found at /admin/commerce/config/stock/settings and choose Local Stock for your product variation.

Related topic can be found here.

EDIT: reading your question again and it seems that you added the field to the product itself, instead of adding it to the product variation. Stock field needs to be attached to the stock variation entity.

  • Hi , I have selected Local Stock but it still does not show the textfield. – harshal Jul 11 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.