I have a bilingual site with localized taxonomy terms used as categories.

I would like to achieve this:



(A propos means about in French)

But I only have:


How can I translate the taxonomy in urls?


I have pathauto configured with i18n terms (which are only available in TAXONOMY TERM PATHS)

enter image description here


Check this post on drupal.org. I am in the same position as you, but it seems that there aren't any solutions for D7.


I'm editing this so it can be visible that this is already possible. As of writing this there wasn't any way of achieving this. As of drupal 8 comming soon there were new modules developed to help translation processes. They are in the core of drupal 8 and available as modules for drupal 7. So the right answer is what @Pere answered in the bellow answer.

| improve this answer | |
  • Welcome to Drupal Answers. If you wish to add a question as a favorite, you can click the star icon to the left of the original question at the top of each page. – Patrick Kenny Apr 21 '12 at 5:04
  • Indeed. Do you think it would work though with translated rather than localised taxonomy? – znat Apr 21 '12 at 18:15

I've been able to do that, using Entity Translation instead of Taxonomy translation (part of i18n) for translating taxonomy terms, and using the Title module to replace the name field of the taxonomy term and making it translatable.

It works so far.

| improve this answer | |
  • But this way when we edit a node it shows origin term not translated terms while adding new nodes ie: in term reference fileds, please suggest ? – jas Feb 29 '16 at 10:32

I'm using this, which supports token. You just need to modify the pathauto rule with the provided token.


| improve this answer | |

If you use the i18n suite of modules, do you have i18n taxonomy enabled?

You can also use the pathauto module to translate your URLs using tokens.

| improve this answer | |
  • Yes, i18n taxonomy is enabled and terms are localized (not translated). I also have pathauto set up with i18n terms but alias are not produced in French when bulk updating. (see screen shot in my edit) – znat Apr 19 '12 at 23:05
  • See @ucaka answer, this is currently an issue with localized terms using i18n and pathauto – Pere Jun 29 '13 at 15:49

Some tokens are not provided by the token list, but do work. Tokens that have :1: in them for instance. Replace the :1: with :0:, and there you go…


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.