0

I'm trying to create a view based on a Solr search index that includes a search form in a block. The view seems to be working based on the preview I see when editing the view. I have set "Exposed form in block: Yes" and "Exposed form style: Basic". The block is assigned to a region, and the block itself is rendered appropriately when the page is displayed. The problem I'm having is that the form is not displayed in the block. I see the block title, but no form and no button. What might I be missing here?

0

Exposed filters on blocks will only work if you've enabled ajax on the view. Try enabling that and your filters should appear

  • I set "Use AJAX" to "Yes" under the Advanced settings. The search form still isn't visible in the block. – Scott Hollenbeck Aug 8 at 17:10
0

I found the solution to my problem. In addition to setting "Exposed form in block: Yes", I had to check the "Expose this filter to visitors, to allow them to change it" option for my "Search: Fulltext search" filter. The search form was properly displayed once that option was set.

  • If this is your answer, please mark it as accepted. – Alfred Armstrong Aug 12 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.