-2

Simple as that. I want to change the H1 tag from taxonomy views to something like "Articles from %term" to make it more user friendly and not redundant (breadcrumbs shows the term alone).

I couldn't find that information in the template or in taxonomy views options.

  • Is it not part of the contextual argument options? – Kevin Aug 19 at 23:30
  • I thought the same thing but I could not modify the title from that options. If I change text to test in {{ arguments.tid }} argument options, i didn't see that changes in pages -cleaning all caches-. – renguer0 Aug 19 at 23:48
0

The Title for the Taxonomy term Views is set to None, so using the Override title from the Contextual filters won't display.

The <h1> on that Views actually comes from the Header option: Global: Rendered entity - Taxonomy term (Global: Rendered entity - Taxonomy term).

That is where you need to change it:

Header Taxonomy term names Page Title

  • Tried changing that view mode, clearing al caches and it didn't work: i.ibb.co/P5zKpCk/taxonomy-title.png Title for Taxonomy View is set to None; same override is applied to Contextual Filters. I'm not using taxonomy twig templates. – renguer0 Aug 20 at 21:40
  • Do you have the two checkboxes checked, especially the one to use tokens from the first row? It's difficult to say why it's not working for you, it should if you have only changed the recommended options. You don't need to clear cache to be able to see the changes, you can use Views Preview to check it. Try Bartik theme just to rule out that it's the theme causing it. – prkos Aug 20 at 22:58
  • I have the two checkboxes checked and I've changed the options as you showed before. I tried in Bartik with the same result. Do you have an idea that what can be wrong with this? – renguer0 Aug 21 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.