1

when I run a composer update --with-dependencies, I get the following error message:

Problem 1
    - don't install drupal/core 8.6.0|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-beta2|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.10|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.11|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.12|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.13|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.14|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.15|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.16|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.17|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.2|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.3|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.4|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.6|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.7|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.8|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.9|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0-alpha2|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0-beta2|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.1|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.2|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.3|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.4|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.5|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.6|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.8.x-dev|remove drupal/drupal dev-master
    - remove drupal/drupal dev-master|remove drupal/core 8.7.6
    - Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master].
    - Installation request for drupal/core ~8.6 -> satisfiable by drupal/core[8.6.0, 8.6.0-alpha1, 8.6.0-beta1, 8.6.0-beta2, 8.6.0-rc1, 8.6.1, 8.6.10, 8.6.11, 8.6.12, 8.6.13, 8.6.14, 8.6.15, 8.6.16, 8.6.17, 8.6.2, 8.6.3, 8.6.4, 8.6.5, 8.6.6, 8.6.7, 8.6.8, 8.6.9, 8.6.x-dev, 8.7.0, 8.7.0-alpha1, 8.7.0-alpha2, 8.7.0-beta1, 8.7.0-beta2, 8.7.0-rc1, 8.7.1, 8.7.2, 8.7.3, 8.7.4, 8.7.5, 8.7.6, 8.7.x-dev, 8.8.x-dev].

I have tried:

composer clearcache
rm composer.lock
rm -R vendor
rm -R core

and then one again:

composer update --with-dependencies

but still this error!!!

My composer.json:

{
    "name": "drupal/drupal",
    "description": "Drupal is an open source content management platform powering millions of websites and applications.",
    "type": "project",
    "license": "GPL-2.0+",
    "require": {
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "^1.4",
        "drupal/address": "^1.2",
        "drupal/admin_toolbar": "^1.20",
        "drupal/commerce": "^2.0",
        "drupal/commerce_variation_cart_form": "^1.0",
        "drupal/config_update": "^1.4",
        "drupal/ctools": "^3.0",
        "drupal/devel": "^2.0",
        "drupal/features": "^3.7",
        "drupal/imce": "^1.6",        
        "drupal/pathauto": "^1.1",
        "drupal/votingapi": "^3.0",
        "drupal/views_flipped_table" : "^1.2",
        "drupal/field_group": "^1.0",
        "drupal/entity_browser": "^2.0",
        "drupal/shortcode": "^1.0",
        "drupal/dropzonejs": "^2.0@alpha",
        "drupal/embed": "^1.0",
        "drupal/token": "^1.0",
        "drupal/webform": "^5.0",
        "drupal/core": "~8.6",
        "drush/drush": "~9.0"
    },
    "replace": {

    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "preferred-install": "dist",
        "autoloader-suffix": "Drupal8"
    },
    "extra": {
        "_readme": [
            "By default Drupal loads the autoloader from ./vendor/autoload.php.",
            "To change the autoloader you can edit ./autoload.php."
        ],
        "merge-plugin": {
            "include": [
                "core/composer.json"
            ],
            "recurse": false,
            "replace": false,
            "merge-extra": false
        },
        "installer-paths": {
            "core": ["type:drupal-core"],
            "modules/contrib/{$name}": ["type:drupal-module"]
        }
    },
    "autoload": {
        "psr-4": {
            "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
        }
    },
    "scripts": {
        "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
        "post-autoload-dump": "Drupal\\Core\\Composer\\Composer::ensureHtaccess",
        "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "drupal-phpunit-upgrade-check": "Drupal\\Core\\Composer\\Composer::upgradePHPUnit",
        "drupal-phpunit-upgrade": "@composer update phpunit/phpunit --with-dependencies --no-progress",
        "phpcs": "phpcs --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --",
        "phpcbf": "phpcbf --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --"
    },
    "repositories": {
        "drupal": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    }
}

What's wrong? Would be grateful for any help?

Thanks

  • Are you using the Drupal template (github.com/drupal-composer/drupal-project)? If so, the command you want is listed on that page as composer update drupal/core webflo/drupal-core-require-dev "symfony/*" --with-dependencies – Jaypan Aug 21 '19 at 4:02
  • @Jaypan – The composer.json first line shows drupal/drupal. The composer.json doesn't list the mentioned dependencies. – leymannx Aug 21 '19 at 5:23
1

You are using drupal/drupal that is deprecated (because upgrading is very hard / impossible). After you have fixed the drupal/drupal problem, follow the normal update instructions.

0

You are using the tilde here: "drupal/core": "~8.6",

From experience I know it is better to pinpoint drupal/core to a certain version. FE "drupal/core": "8.6.17", This leaves composer with no other choice than going for that version of core.

In case you are using the webflo template you have to run another command: composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

Or find this package in the composer.json and also pinpoint it to the core version you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.