0

I have been manually updating Drupal 8 core successfully until now. When I try to update from 8.7.6 to 8.7.7 it goes to a new install.

Here is what I did

  1. Back up database, and back up entire site folder to my computer hard drive
  2. Upload new Drupal Core folder to my computer hard drive
  3. Remove modules, profiles, sites, themes folders from new Drupal Core folder
  4. Swap in old modules, profiles, sites, themes and libraries folders from old Drupal site to new Drupal Core folder
  5. Upload new Drupal core folder to c-panel
  6. Put site into maintenance mode
  7. Change name of original site to "Old original site"
  8. Change name of Drupal Core folder to "original site"
  9. Take site out of maintenance mode

In the past, this worked, and the site was updated. This time, the site goes to a new-install. To deactivate the new install, I went back to the c-panel, and renamed everything to the original names, and the site was back to its original un-updated state.

  • Welcome to Drupal Answers :) Imagine someone hearing from your problem the very first time, please provide as much info as you can, even when you think it may be self-explanatory. We need all steps to reproduce the problem. Is it a Composer project? How exactly are you trying to update? What's special about your project? Please update your question accordingly. Many thanks. – leymannx Sep 9 at 6:20
  • 4
    Maybe you've overwritten the settings.php file. Add it back and add the database credentials again. You might also try to perform the new install routine and add the correct database credentials, then Drupal will recognize the existing installation. Please only do that after backing up your database. – leymannx Sep 9 at 6:24
  • Could you try performing the same steps on a different environment, preferably your local computer? That could point to the probable cause. Good luck in any case! – Stefanos Petrakis Sep 11 at 13:06
  • Hi, Mary. I guess we could find the solution / trick to solve your problem, but I really, really recommend that you start using the Composer workflow. Updating manually will become harder and harder. Since updating with Composer (normally) is very easy, I recommend do the switch now to get the benefit as early as possible. If you can't run composer on your host / server, do it locally on your computer and upload all the files. I could have posted this comment (with some links to the relevant docs on drupal.org) as an answer, but I guess it isn't ;-) – hansfn Sep 11 at 15:05
  • Thank you for your help. I've tried manually updating many times. When I do the steps as described above, then go to mywebsite.com/update.php, instead of going into the update routine, it says The website encountered an unexpected error. Please try again later. I have updated about 5 times in the past year, and have not encountered this error before. – MaryV Sep 16 at 4:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.