0

i have created a view for XML feeds. But when I access the link for feeds it gives me below debug info at top of xml feeds:

<!-- THEME DEBUG -->
<!-- CALL: theme('views_view_views_rss') -->
<!-- BEGIN OUTPUT from 'sites/all/themes/hme/templates/views-view-views-rss.tpl.php' -->

<?xml version="1.0" encoding="utf-8" ?><rss version="2.0" xml:base="http://example.com" xmlns:atom="http://example.com/2005/Atom" xmlns:dc="http://example.org/dc/elements/1.1/" xmlns:media="http://example.organoc.org/mrss/">
<channel>
  <title>H

I want to remove the comment part only displaying before tag...

  • Because you enable debug theme. Just turnoff in setting.php $conf['theme_debug'] = FALSE; – MrD Sep 10 at 10:28
  • its already set to "FALSE" – Rohan1990 Sep 10 at 10:45
  • try drush vget theme_debug to see theme_debug really set to FALSE. If already try drush cr all. – MrD Sep 10 at 10:57
  • Wherever you enabled Twig debugging, disable it. We don't know where you enabled it. You have to know that. We only can guess, which makes this issue too broad. – leymannx Sep 10 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.