0

Commerce kickstart comes with a view named Collection products that shows: a Collection of products (Product display).
In the relationship's tab of this view there are 2 relationships:
1. Product category field_product_category
2. Belongs to Collection field_collection.
The contextual filter is set to: Indexed Node: Product category (field_product_category) and the path to this page is product_category/%.
There is a menu block showing above this view that comes from the same view showing all the category terms as links.
When you click them, you see that the view shows correctly all the products referring to that term.
My problem is that the term that is active (e.g. url: category/beef) doesn't show as a title right above the view or in the block.
How can I achieve that?

0

Edit your Contextual filter and you'll see the option to override the title in the section for when the filter argument is present or a default is provided.

You can use tokens from the Replacement patterns section to construct the title text.

Your "menu" is likely also coming from the Contextual filter, set to the "Summary" option.

Another way is to add the title in the Views Header, you can see how it's implemented in the "Taxonomy term" Views.

  • I tried editing the contextual filter and I've changed both (under Exceptions AND under "When the filter value IS in the URL or a default is provided") options for overriding the title with %1 as that is what is recommended but nothing shows after saving. (even after clearing caches). – BassPlaya Oct 11 at 3:08
  • Can you add screenshots to your question about your configuration and how you're testing it's working? There must be something we're missing. – prkos 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.