I have a Drupal 8 site that has been installed with Composer. Last week, I updated Search API 1.14 and Search API Solr 3.7.

The module are in the good version, but when I run drush updatedb, the following error appears.

[error] Search API Solr requiert ce module et cette version. Vous utilisez actuellement Search API version (Currently using Dépendance non résolue Search API (Version >=8.x-1.14 requise))

[error] Search API Solr requires this module and this version. You are currently using Search API version (Currently using Unresolved Dependency Search API (Version> = 8.x-1.14 Required))

I checked the installed version and it is the last one. How can I fix this error?

The content of the composer.json file is the following.

    "drupal/search_api": "^1.14",
    "drupal/search_api_autocomplete": "^1.0",
    "drupal/search_api_location": "^1.0",
    "drupal/search_api_solr": "^3.6",
  • Have you run the composer update command after updating the versions in your composer.json? Oct 8, 2019 at 2:08
  • @AnsonWHan yes and this has updated to the latest versions
    – Mathieu
    Oct 8, 2019 at 4:05
  • Sometimes deleting the whole vendor folder and running composer install again might help Oct 8, 2019 at 11:28
  • @IsmailCherri Is it safe? Should he just do sudo rm -R /vendor ?
    – Mathieu
    Oct 8, 2019 at 12:31
  • @IsmailCherri Do you have to composer install or composer update --with-dependencies ?
    – Mathieu
    Oct 8, 2019 at 13:08


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.