0

I am running into an issue where running drush bam-backup is never completing. It ran for about 18 hours and nothing happened..

The command works and completed on our staging server within about 45 minutes, and when I run SELECT SUM(data_length / 1024 / 1024) FROM information_schema.TABLES; from the sql console, I get a result of 963MB.

On our production server, the same sql query, I get a result of 2.835GB. At most I would expect the back up on production to take at most 3 times as long as it does on staging, but 18 hours seems like something is wrong...

We originally thought that it could be because the db was too large because of all the revision tables, so we cleaned those out; the production database was 109GB before cleaning out the field_revision_field% tables :mind-blown:!

After cleaning them out it's now at 2.835GB.

What could cause drush bam-backup to never complete and just hang there for 18+ hours? I tried running the drush bam-backup command with -v to spit out everything that is happening, but it just says starting backup... and nothing else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.