1

I have a remote server which I initially setup with a default Drupal 8.7.7 install. I have since been building the site on my local development server and would now like to transfer the developments to the remote server.

I exported the configuration using drush config:export

I committed the the exported items to git and pushed them to the remote server. I then ran composer install --no-dev followed by drush updb on the remote server and logged in.
I then went to the configuration synchronization setting and clicked on the import all button.

Everything seems to be working fine however 12 items will not sync. I have tried importing them via the import -> single item option and tried importing everything via drush cim, however the following items still will not sync and show no errors: enter image description here

I have repeated the process a number of times to check it wasn't a one off error.

The only similarity I can see is that they are all core.entity_view_display settings apart from the one core.entity_form_display item. Each one has different differences.

How can I debug why these items won't syncronize?

1

It appears as though the issue I had relates to this issue: Display mode configurations don't get updated with new fields https://www.drupal.org/project/drupal/issues/2915036

I haven't tried the patch yet, but after saving the individual display modes the fields then get put into the export and sync properly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.