I setup a Solr search index (Solr 7.7.1 and Search API Solr 3.2) with custom entities. I have several fields indexed and 2 of them are fulltext. Additionally :

  • I setup the view with an exposed filter in a block (page view)
  • No Ajax option is set
  • I have a filter Search enabled : Fulltext Search with following options :
    • Expose this filter to visitors
    • Signle filter
    • Contains any of these words
    • Allow multiple selections
    • Parse mode : direct query
    • All Fulltextfields selected
  • Exposed form settings
    • Exposed form in block : YES
    • Exposed for style : basic
  • I also setup some facets on other fields

When I come to the page, all results are displayed by default. When searching for any term(s) via the Full-text textfield, I am getting blank results. Instead if I select some facet options, results do show up accordingly to the facets.

How can I get the Fulltext search to work?

  • In your Search API index, are your text fields (e.g. title, body, and the like) marked as "fulltext"? Otherwise, searches will have to match full strings and not words. Note that changing this will require a index rebuild.
    – CG Monroe
    Nov 4, 2019 at 16:00
  • Yes, the textfields are marked as "fulltext" and I re-indexed. Any tip on how I could go about debugging this issue of no results returned? I'm at a loss
    – aspy
    Nov 4, 2019 at 18:31

1 Answer 1


After several hours, I discovered that search_api_solr 8.x-3.7 was the issue. I downgraded using composer to the latest v2.7 and it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.