0

A site using MAYO 7.x-1.2 was moved from a Windows IIS to a Linux server. Shortly thereafter, all background colors defined in MAYO settings (and also any custom CSS) have disappeared. Also gone is the custom background color for dropdown Nice menus – it just goes transparent. Other than the bg color, main content and layout are OK. Perhaps there is no relationship of this to the server change, but in any case I haven't been able to debug this with anything I tried. The PHP version is now 7.2, maybe that is related, and I'm not sure what it was under the Windows server. Site needs to stay in D7 for now, although a D8 upgrade is planned.

Also note, I was aware that this is an old version of MAYO that should have been updated long ago. I hesitated to update because I had modified the template file to get an additional region, and wasn't sure how to apply the update while preserving the custom region. (Could use some advice there.) In reading the docs about the security update, it seems the circumstances for risk don't really apply for this site.

Advice on either of these issues will be much appreciated.

  • Missing CSS, files folder not writeable, tmp not writeable, locations of these dirs changed... could be anything. There must be some logs around this. – Kevin Nov 10 '19 at 16:51
  • Often this is due to missing or misconfigured .htaccess. Yeah, or as @Kevin suggests, file/folder permissions/ownership. – leymannx Nov 10 '19 at 17:43
  • Setting 777 permissions on the theme folder, or on /files inside /default, didn't help. I'm aware of .htacces but not familiar with all its purposes. Can anyone comment: If a site is moved from a Windows server to Linux, should .htaccess need some changes? – Charles Nov 10 '19 at 20:04
  • 3
    @Charles you need to change the folder's owner/group. Without the proper owner/group it wont work even when perm is set to 777. – No Sssweat Nov 10 '19 at 23:33
1

First , Check Administrator -> Configuration -> Media -> File System to personalize your tmp path. Make sure to use relative paths and have the right privileges for your webserver.

After than Check permission of the /sites/default/files and make sure it's writeable by your web server.

| improve this answer | |
  • Pardon my lack of deeper knowledge on server matters, but if /files is set to 777 permissions, should that mean it's "writeable by the server"? – Charles Nov 10 '19 at 20:38
  • 1
    @Charles, yes 777 is writeable but very dangerious. you should set the owner and group of the files by your webserver then set it to 755 later. – Yuseferi Nov 10 '19 at 20:42
  • @Charles,any update? have this solution worked for you? – Yuseferi Dec 16 '19 at 5:52
  • Yes, that was solved. Since a variety of things were being done including changes made by a hosting server admin, I am not completely sure which modification was the one that fixed that particular problem. But I think it was server-specific changes in the settings.php file. – Charles Dec 16 '19 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.