2

My server is using PHP version 5, therefore, I need to install Drupal 8 version 8.6.18. But when I try, composer create-project drupal-composer/drupal-project:8.x-dev my_site_name_dir --no-interaction --no-install, I get the following error.

  [InvalidArgumentException]                                                   
  Could not find package drupal-composer/drupal-project with version 8.x-dev   
  in a version installable using your PHP version 5.6.40.  

Is there anyway to install 8.6.18 with composer?

  • 2
    PHP 5 is no longer getting security fixes, not supported by PHP nor D8, 2 times slower than PHP 7. Thus, upgrade to PHP 7. – No Sssweat Nov 16 at 1:00
  • Is there a reason why you are still running PHP 5.6? – anoopjohn Nov 16 at 1:54
1

Drupal 8 does not support PHP version 5. It requires a minimum PHP version of 7.0. Please see here for Drupal install requirements

Drupal Installation Requirements - Drupal.org

So you will have to upgrade PHP on your machine. Also PHP 5.0 is no longer supported and is not secure. So you might want to upgrade PHP on your server any way.

PHP Supported Versions - php.net

  • thank you very much! – Panda Nov 16 at 3:54
  • 1
    Sure. Good luck with your trying out Drupal. The community will be more than happy to help you with issues if you run into any. – anoopjohn Nov 16 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.