1

I am using Drupal 7 and the Backup & Migrate module to restore (or import) a drupal install that works fine on a different computer. When I run the import process everything seems to work fine, except that Clean URLs seems to break and I don't know why.

Here are the steps I've gone through:

  1. I have a Drupal install working fine on Computer 1 (MAMP and Mac Lion OSX).
  2. I push the code to Github and export the database with the Backup & Migrate module.
  3. On Computer 2 (also MAMP and Mac OSX Lion), I import the Github repo and install a clean Drupal site.
  4. At this point, Clean URLs are working for the new install on Computer 2.
  5. On Computer 2, I then go to the Backup & Migrate module and restore the database from Computer 1
  6. The install runs just fine, except that suddenly Clean URLs are broken.
  7. There are no logs that give a new error. The Clean URL test simply fails with no other feedback.

I can only imagine that something in the database is causing this issue since the Backup & Migrate restore should not be changing the .htaccess file, folder permissions, or Apache.

Any ideas out there why a database restore would break Clean URLs?

  • I'm not sure about the cause of your issue but have you tried doing a sql-dump with drush and then importing that? (Or some other method of dumping and importing the database besides Backup and Migrate?) It would be useful to know whether it is only Backup and Migrate or something in your database/configuration itself. – Patrick Kenny Apr 19 '12 at 17:06
  • 1
    I should have added that yes, I've tried the same process with a phpMyAdmin export/import process with the same exact results. Not Drush, but another process with identical results. – Randy Burgess Apr 19 '12 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.