1

I have a vocabulary called Industry with four terms. I have edited the terms to keep the URL to be automatically generated. They are following this convention:

industry/term1, industry/term2, etc...

I want the convention to be (without the "industry/"):

term1, term2, etc...

I configured the URL alias patterns like so for Taxonomy Term paths:

Default pattern: [term:vocabulary]/[term:name]

Pattern for all Industry paths: [term:name]

However, when I navigate to the URL (i.e. /term1), I get this message:

The requested page "/term1" could not be found.

On top of that, I have a view for a block that generates this vocabulary as a list with the links so users can click on them and go to the taxonomy page. I have the option selected for each term:name that we need to "Link this field to its taxonomy term page". When that block is rendered, it generates a URL like so:

[term:vocabulary]/[term:name]

This is not what I expected. I expected the URL to be [term:name]. I am new to Drupal and still learning things about it. What am I doing wrong?

1

Please check if you have a URL Alias in the system for "/term1".

It might be mostly the case of all your old Alias existing in the system not the new once. If you don't find the update URL alias under admin/config/search/path. Then it just a simple bulk regenerate (admin/config/search/path/update_bulk).

Please ensure you have selected

  • Taxonomy term
  • Update the URL alias for paths having an old URL alias (at Times you may want to use the option Regenerate URL aliases for all paths)

enter image description here

| improve this answer | |
  • I just tried that and got the message "no new URLs to generate." – Bobort Nov 22 '19 at 23:12
  • 1
    Try with generate url alias for all paths, try to delete alias for all taxonomy terms from the delete tab – berramou Nov 23 '19 at 0:04
  • Okay, thank you so much, @berramou! I had to delete all the aliases. And then I had to regenerate them! – Bobort Nov 25 '19 at 15:34
  • 1
    Welcome I'm glad that helped – berramou Nov 25 '19 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.