When I want to install Drupal Commerce using Composer via Git Bash terminal and using the following command:

$ composer create-project drupalcommerce/project-base mystore --stability dev

I get the following error:

[InvalidArgumentException] Could not find package drupalcommerce/project-base with stability dev in a version installable using your PHP version 5.6.40.

create-project [-s|--stability STABILITY] [--prefer-source] [--prefer-dist] [--repository REPOSITORY] [--repository-url REPOSITORY-URL] [--dev] [--no-dev] [--no-custom-installers] [--no-scripts] [--no-progress] [--no-secure-http] [--keep-vcs] [--remove-vcs] [--no-install] [--ignore-platform-reqs] [--] [] [] []

So what can I do?


1 Answer 1


The package that triggers the error is drupalcommerce/project-base. If you check the composer information for that package you see:

  "require": {
        "php": ">=7.0.8",
        "ext-curl": "*",
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.6.5",

As you see, it requires PHP 7.0.8 or higher. You have PHP 5.6.40. You should upgrade your PHP, not only because this package but also because PHP 7.x is much faster and PHP 5.6 is not recommended anymore, not to forget that PHP 5.6 end of life was hit a year ago, on the beginning of 2019.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.