0

I am preparing for a Drupal 8 Core module (Current version is 8.7.4) and in the process, I used 'drush ups' to check for available module updates. Doing this command generates the 'following module is missing from the file system' problem. Here is the following log:


The following module is missing from the file system: ds_test_layout_theme bootstrap.inc:278                                                       [warning]
Unknown path for ds_test_layout_theme module.                                                                                                      [warning]
The following module is missing from the file system: webform_test_bartik bootstrap.inc:278                                                        [warning]
Unknown path for webform_test_bartik module.                                                                                                       [warning]
The following module is missing from the file system: webform_bootstrap_test_theme bootstrap.inc:278                                               [warning]
Unknown path for webform_bootstrap_test_theme module.                                                                                              [warning]

I tried to look for the specific modules in my filesystem and they actually existed in my file system. I did some research and some posts suggested to use 'drush sql-query delete' to remove the module from the database. However, when I tried to query for that specific module in the database it yields no results which means the aforementioned solution would not work. I appreciate any suggestions or solutions to solve these warnings so that I can feel safe to do the updates.

One other question is: are these warnings actually dangerous? Since I noticed that the missing modules are the test modules of a 'bigger' module. 

Thank you!

  • Did you tried this drush sql-query "DELETE FROM key_value WHERE collection='system.schema' AND name='ds_test_layout_theme';" check drupal.org/node/2487215 – berramou Dec 2 at 21:56
  • I did that but it doesn't fix it. Moreover, the entry does not exist in the database in the first place when I queried it. Thanks for the link, I am looking through if any of the solutions apply to my problem. – vin0298 Dec 3 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.