0

I have the exact same problem as in How to solve "Query failed" error in drush sql-sync output?, exact same output. That user found the answer as the password in settings.php was wrong, but my password is correct and it still doesn't work. Can anyone please help?

drush sql-query --strict=0 --file=/tmp/mob_20191203_224013.sql.gz --file-delete --uri=mob --root=/home/fc/1/de/mob/web -vvv
 [preflight] Config paths: /home/fc/1/de/mob/vendor/drush/drush/drush.yml,/home/fc/1/de/mob/drush/drush.yml
 [preflight] Alias paths: /home/fc/1/de/mob/web/drush/sites,/home/fc/1/de/mob/drush/sites
 [preflight] Commandfile search paths: /home/fc/1/de/mob/vendor/drush/drush/src,/home/fc/1/de/mob/drush
 [bootstrap] Starting bootstrap to max [0.04 sec, 8.57 MB]
 [bootstrap] Drush bootstrap phase: bootstrapDrupalRoot() [0.04 sec, 8.57 MB]
 [bootstrap] Change working directory to /home/fc/1/de/mob/web [0.04 sec, 8.57 MB]
 [bootstrap] Initialized Drupal 8.7.10 root directory at /home/fc/1/de/mob/web [0.04 sec, 8.76 MB]
 [bootstrap] Drush bootstrap phase: bootstrapDrupalSite() [0.04 sec, 9.06 MB]
 [bootstrap] Initialized Drupal site mob at sites/default [0.04 sec, 9.29 MB]
 [bootstrap] Drush bootstrap phase: bootstrapDrupalConfiguration() [0.04 sec, 9.29 MB]
 [debug] Add service modifier [0.04 sec, 9.45 MB]
 [info] Executing: command -v mysql [0.05 sec, 9.91 MB]
 [info] Executing: mysql --defaults-file=/tmp/drush_IsKDek --database=mob --host=localhost --silent -A < /tmp/mob_20191203_224013.sql.gz [0.05 sec, 9.96 MB]

In SqlCommands.php line 199:

  [Exception]    
  Query failed.

/tmp/mob_20191203_224013.sql.gz exists, /tmp/drush_IsKDek does not Drush is 9.7.1, Mint 19.2, alias

loc:
  root: /home/fc/1/de/mob/web
  uri: mob
  options:
    command-specific:
      sql-sync:
        sanitize: true
        structure-tables:
          common:
            - cache_advagg
            - cache_bootstrap
            - cache_config
            - cache_container
            - cache_data
            - cache_default
            - cache_discovery
            - cache_dynamic_page_cache
            - cache_entity
            - cache_menu
            - cache_page
            - cache_render
            - cache_toolbar
            - watchdog
            - history
            - sessions
    os: Linux
  paths:
    dump-dir: /tmp
    files: sites/default/files
3
  • Have you had a look at SqlCommands.php line 199? – leymannx Dec 4 '19 at 7:58
  • Yes. Nothing useful. $result = $sql->query($query, $filename, $options['result-file']); $query is empty, filename is the .gz archive, resultfile empty, $result empty. – user12869 Dec 4 '19 at 22:57
  • Probably better to report this one at GitHub. github.com/drush-ops/drush/issues – leymannx Dec 5 '19 at 6:57
0

At the time of writing this comment, there is a problem in drush 9 with php7.4 as mentioned here: https://github.com/drush-ops/drush/issues/4319#issuecomment-649223069

I solved it in my case (I have multiple PHP versions installed) by switching to php7.2 using this command: sudo update-alternatives --set php /usr/bin/php7.2

I think it will work also with php7.0 and php7.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.