4

I'm using https://github.com/drupal-composer/drupal-project to install Drupal 8. The only thing I've changed in the composer.json is to freeze Drupal core version to 8.8.1

After Drupal installation I get WSOD and see the following errors in PHP logs:

Uncaught PHP Exception InvalidArgumentException: "Class "\Drupal\system\Controller\Http4xxController" does not exist." at /var/www/html/web/core/lib/Drupal/Core/DependencyInjection/ClassResolver.php line 24
Uncaught PHP Exception InvalidArgumentException: "No check has been registered for access_check.permission" at /var/www/html/web/core/lib/Drupal/Core/Access/CheckProvider.php line 97

Happens on PHP 7.2 and 7.3

UPD: this issue does not happen with Drupal 8.8.0

UPD2: This issue happens regardless of whether you freeze drupal core or not. Also happens with the (now) official composer template drupal/recommended-project. This issue happens only during installation from web, if you install via CLI it doesn't happen. There's an issue now in the official Drupal tracker https://www.drupal.org/project/drupal/issues/3103529. P.S.: I don't know why someone decided to close this issue as not relevant to Drupal. This is the Drupal core issue. I tried to reopen a couple of times but my request was ignored.

10
  • 1
    Have you already tried composer update --lock && composer install? Or if this didn't work rm -rf vendor/ && rm -rf composer.lock && composer install? And what do you mean by Drupal installation? How did you install? On an existing installation or a fresh install? – leymannx Dec 20 '19 at 8:14
  • The Http4xxController class exists in Drupal 8.8.x. It seems that the dependencies have not been all installed. – kiamlaluno Dec 20 '19 at 8:40
  • @leymannx this is a fresh install github.com/wodby/drupal/blob/master/8/Dockerfile#L19-L25. By installation, I mean clean drupal installation from a browser. You can clone latest github.com/wodby/docker4drupal and try it yourself – chingis Dec 20 '19 at 9:03
  • @kiamlaluno I've looked it up and the class with this namespace actually exists in the codebase. So it's not a composer dependencies issue. Most likely something wrong with the dependency injection container built after the installation – chingis Dec 20 '19 at 9:05
  • 4
    This is a valid bug, I created an issue for it at drupal.org/project/drupal/issues/3103529 - it seems to happen only on http installation for me. – rfay Dec 28 '19 at 23:44

Browse other questions tagged or ask your own question.