0

When i tried to update my project using composer from 8.7.9 to 8.8.1 i get the following error:

Command:

composer update drupal/core --with-dependencies

[Composer\DependencyResolver\SolverProblemsException] Problem 1 - Installation request for drupal/core 8.8.1 -> satisfiable by drupal/core[8.8.1].
- drupal/core 8.8.1 requires guzzlehttp/guzzle ^6.3 -> no matching package found. Problem 2 .
- drupal/core 8.8.1 requires guzzlehttp/guzzle ^6.3 -> no matching package found.
- drupal/ultimate_cron 2.x-dev requires drupal/core ^8.5 -> satisfiable by drupal/core[8.8.1].
- Installation request for drupal/ultimate_cron ^2.0 -> satisfiable by drupal/ultimate_cron[2.x-dev].

Potential causes:
- A typo in the package name .
- The package is not available in a stable-enough version according to your minimum-stability setting . see https://getcomposer.org/doc/04-schema.md#minimum-stability for more details.
- It's a private package and you forgot to add a custom repository to find it

Any ideas ?

  • Run composer clear-cache and try again – Clive Dec 24 '19 at 19:18
  • I have tried, the same result! – berramou Dec 24 '19 at 19:30
  • Maybe try composer update drupal/core guzzlehttp/guzzle --with-dependencies – Clive Dec 24 '19 at 19:46
  • I have tried it too, the same error – berramou Dec 24 '19 at 20:09
0

I have just to remove the vendor Folder it works now:
For the complete steps see 8.5.6 Update not being recognized .

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.